Mailing List Archived Message #11

From: "Lewis G Rosenthal" <> Full Headers
Undecoded message
Subject: Re: [eCS T60/T61] ACPI issues
Date: Mon, 14 Apr 2008 17:53:58 -0400
To: eCS ThinkPad T60/61 Mailing List <>

On 04/14/08 01:53 pm, Carl Gehr thus wrote :
On Mon, 14 Apr 2008 11:38:49 -0400, Lewis G Rosenthal wrote:

On 04/14/08 12:32 am, Chuck McKinnis thus wrote :
Lewis G Rosenthal wrote:
Chuck, I know that you have been successful with using OS2APIC.PSD. I am able to get ACPI 3.0.7 working for both CPU cores, as well as APM.ADD.

What version(s) of ACPI did you test, and aside from the "hang during boot" issue I see with 3.0.8, what were your results? I am seeing random deadlock conditions, but I can't tell whether it's an ACPI issue, uniaud, GenMAC, or something triggered by Flash (using my patched 9.0.115 plugin).


I just tried the latest 3.08 (04/13/2008).  Traps in APM right after SDDHELP.SYS is loaded.  It also displays a bunch of ACPI messages that should not be there.  If I rem out all of the APM lines, it will boot. I also have sound (not very loud) using test1.

I am using Panorama on this T61. I believe Panorama is required for APM.

I've seen comments that Panorama is required for various functions. But, I have also seen coments about cautions, problems, etc., that I
did not really understand.  So, I am still using the latest SNAP and
having no problems.  OTOH, I don't know if I am missing something
either.  [That's the penalty of being a techo-dummy on eCS.]

I was under the impression that in order for APM.ADD to properly suspend/resume, Panorama was required, but this may have been from an earlier build.
I have 3.0.8 working, based on Neil's posting about the Intel 945GCNL (I have one of those machines in the next room, which is yet to be delivered to a client), by adding /SAP:0x20 to my PSD line, which now reads:


Standard Q#1:  What does /SAP do and why should I care?

See Chuck's comment. I don't know much more about this (yet).
In addition, I have:


Yes...  Me too.

I am currently testing with only the defaults in the CFG files.

I'm not totally sure what I may have changed other than I've set the
'Close Lid' to do nothing.  So far, it has worked just fine.  [Makes it
easier to carry the TPad up/down the stairs than when it is open.]

I have Diane's set the same way.

I did notice that I currently have no suspend working at all.
The extra info you;re getting may be caused by:

LogScreen = 1

Hmmm...  I have LogScreen=0
BUT, I when I do a PrtSc, it works just fine.
I've never bothered to change it because of my oft-said
basic view of the world:
  If it ain't broke, don't fix it.

LogScreen = 0 is the default, and does not output the debug information to the screen during boot. With this turned on (and I found 3.07 to want to do this even with it off!), you get a bunch of messages during the boot cycle (before PrtSc would be of any use, actually).

For sound, I have the following in my unimix setup params, loaded from startup.cmd (unimix.exe -loadc:\mmos2\unimix.ini):

-id3 -cnt0 -val1
-id3 -cnt1 -val1
-id27 -val33

I have nothing that I can find about 'unimix'...

Yes, there is a \mmos2\unimix.exe, but no *.ini anywhere that I see.

I just named my dumpfile unimix.ini. I could have called it Fred_and_Ethel.
Should I have something?  ISTR that Paul said his updates, current and
planned, are intended to avoid a user having to deal with this.

Yes, that is his goal. I found that when I used the initial setting per Curtis, I was only enabling the left speaker (channel), so I added the rest. I then set the preferred volume. I currently have no hardware volume control except for mute; the up/down buttons have no effect, and I guess this is due to ACPI.
(N.B.: Those are not the contents of unimix.ini, merely the relevant settings. Set them manually, as parameters passed to unimix.exe, and then use unimix.exe -savec:\mmos2\unimix.ini to dump them.)
I attempted to patch Flash to the 9 level, but I am not sure that I did the hex edit correctly.  What is your patched one based on?  Might I get a copy?

My patched one is based on the original 7.0 r14. I seemed to get more stuff patched than Steve Wendt did with his, so I kept it (I had a few sites which were looking for the ident string in different places). You may download the patched version (and the preceding one, patched to 9.0 r47) from . The zip is 500+ KB, and perhaps best not attached to an email on the list. I'll send both via PM, though.

Lewis, I've got no problem with direct E-Mails w/ large files attached.
 I send/receive much larger than that all the time.  Your latest
patched Flash would be appreciated.

I'll send you what I sent to Chuck. I just don;t like to do that to a mailing list (although this one is small, and I have a 3MB size limit set for attachments), as I never know where people might be or on what device they may be receiving messages (cell phone with larger limit set for message size, etc.).
[I try to avoid anything associated with Yahoo.  I already get a dozen
or so per week spam/phishing stuff from there as it is.]

I hear you! :-)

Lewis G Rosenthal, CNA, CLP, CLE
Rosenthal & Rosenthal, LLC
Accountants / Network Consultants
 New York / Northern Virginia 
eComStation Consultants        
Novell Users Int'l
Need a managed Wi-Fi hotspot?     

Subscribe: Feed, Digest, Index.
Mail to ListMaster