Mailing List Archived Message #123

From: "Carl Gehr" <> Full Headers
Undecoded message
Subject: Re: [eCS T60/T61] uniaud32.sys v1.9.4 SVNr353 crashes
Date: Sun, 18 May 2008 11:34:52 -0400 (EDT)
To: "eCS ThinkPad T60/61 Mailing List" <>

On Sat, 17 May 2008 22:17:26 -0700 (PDT), Jon Harrison wrote:

>I've not installed audio since purchasing my TP61.

First, I am using a T60 not a T61, so there are obviously potential
differences.  YMMV...

>Today I installed uniaud114rc2, substituting uniaud32.sys v1.9.4.
>(debug version).

Because of potential confusion with various test drivers, I'm going to
use actual driver date/times to identify what I have been using prior
to Paul's latest update.  I believe these to be from the distributions
>     uniaud16.sys    72912   4-18-08  10:20p

>     uniaud32.sys   574658   4-01-08   6:56a

I have tried so many of Paul's test levels and the above were the best
combination for my system.

All of the other 1.9.3 tests and combinations thereof caused various
lockups.  OTOH I do not recall any traps during the boot process with
any of the tests.

I installed the updated 1.9.4 level of UniAud32.  No boot problems, but
my 'standard' first test is a YouTube version of the Doubletree Hotel
commercial with Dinah Washington's 'Relax Max'...
    Works with the 1.9.2 level above.
    DOES NOT work [SYSTEM LOCKUP] with 1.9.4.

Again, though, boot is OK, so not exactly the same as yours.

>On bootup, after genmac wrapper loads I get a trap.

A standard question for T6x issues:
*  Do you have:
as the first executable in the Config.Sys?


>the kernel is 14.104a_smp

I am using the same kernel. on my T60

>I thought it odd that FAT32 is referenced, I commented out cache32
>but did leave in the fat32.ifs.  I figure since it is an ifs it
>loaded early on and was not a factor in the trap.
>Other than removing the ifs, any suggestions?

I have:
  IFS=o:\OS2\BOOT\FAT32.IFS /CACHE:2048 /H /Q
using the FAT32 0.9.11 version.  I have not tried the 0.9.12, nor the
0.9.12 with the fix to a problem that was reported.

>I tried adding /C:ICH to the device driver line without any
>Does this sound like a known problem with the tp61?

The other almost standard question for any T6x issue:
    What ACPI are you using and what are your switch settings?

I am using:
      [Note:  APM.SYS is not compatible with ACPI]

Don't know that this will be much help since our environments are
somewhat different.  But, the solutions these days seem to be more art
than science.


Subscribe: Feed, Digest, Index.
Mail to ListMaster