Mailing List Archived Message #3

From: "Carl Gehr" <> Full Headers
Undecoded message
Subject: Re: [eCS T60/T61] ACPI issues
Date: Sun, 13 Apr 2008 14:08:25 -0400 (EDT)
To: "eCS ThinkPad T60/61 Mailing List" <>

On Sun, 13 Apr 2008 11:10:06 -0400, Lewis G Rosenthal wrote:

>Chuck, I know that you have been successful with using OS2APIC.PSD. I am
>able to get ACPI 3.0.7 working for both CPU cores, as well as APM.ADD.
>What version(s) of ACPI did you test, and aside from the "hang during
>boot" issue I see with 3.0.8, what were your results? I am seeing random
>deadlock conditions, but I can't tell whether it's an ACPI issue,
>uniaud, GenMAC, or something triggered by Flash (using my patched
>9.0.115 plugin).

Well, I'm not Chuck... ;-)  But I'll butt in a bit...

First, a question:  What is APIC and why should I care?

I tried using /APIC on my T60 and could never get past the boot-time

Just for the record in this list, my ACPI settings and some 'Rem Notes'
about what I tried and why are:

>Rem  **CG**  PSD=ACPI.PSD     <==== Original; next from 1.2R on C:
>Rem  **CG**  Chgs for SMP made to V2.0 RC2:  09-Sep-2007
>Rem  **CG**  Removed /NOD ==>  Doc:  This is now default...
>Rem  **CG**  Removed /R   ==>  Doc:  Supposed to fix reboot, but...
>Rem  **CG**  PSD=ACPI.PSD /SMP  <==== Add /APIC <==== BOOT HANG!
>Rem  **CG**  PSD=ACPI.PSD /SMP  <==== Add /EIS  to see if boot in Dock
>Rem                                   Didn't help, but didn't hurt...
>Rem  **CG**  PSD=ACPI.PSD /SMP  <==== Add /ALS  Ref: ACPI.Doc
>Rem                                   Didn't help, but didn't hurt...
>Rem  **CG**  PSD=ACPI.PSD      /EIS  /ALS
>--------------------------- 57 LINE(S) NOT DISPLAYED ------------------
>-------------------------- 126 LINE(S) NOT DISPLAYED ------------------
>Rem **CG** See below - Per Lewis 20-Oct-2007 RUN=O:\OS2\CMD.EXE /C O:\O

I can run just about every function at this point with UniAud 1.9.2.
This obviously excludes those functions that require newer Flash, PDF,
etc., levels that are just not available for eCS.

I'm open to adjustments if there is a benefit.  But, I hate to mess
with success.

OTOH, UniAud 1.9.3, including all of the special test files Paul
provided, caused various problems.  I sent the debug files to Paul and
it sounds like he is doing some major surgery for the device type that
we have in the T60/T61.

And, since you brought it up, my 'Patched' reports:
     Shockwave Flash 9.0 r14
What/where did you get the more recent update?  Can you play video at:
that specifically states:
    "Flash version 9.0.115 is required for the Augusta Live
    video service."
I'd really like to see what's there, but it either demands an update or
just does not play.


Subscribe: Feed, Digest, Index.
Mail to ListMaster