Mailing List efte-dev@2rosenthals.com Archived Message #41

From: "Gregg Young" <efte-dev@2rosenthals.com> Full Headers
Undecoded message
Subject: Re: [eFTE-dev] Ctags
Date: Sat, 30 Dec 2017 14:35:07 -0700 (MST)
To: "eFTE Developers Mailing List" <efte-dev@2rosenthals.com>

On Fri, 29 Dec 2017 21:11:40 +0100 Alfredo Fernández
Díaz wrote:
>
>Hello,
>
>Gregg Young wrote:
>>Hi
>>
>>The tags don't work in eftepm the way the new help
>>implies.
>> From the help:
>>
>>Typically, you would want to know if something in one
>>file is referenced in others. Once loaded in the editor,
>the
>>tags file acts as a proxy allowing to jump between all
>>references in the 'regular' files to the items listed in
the
>>tags. Some additional examples could be:
>>
>>I created the tags file with ctags.exe version 5.8. It
>does
>>generate an error (see below) but a tags file is
>>generated. The help says I should be able to jump
>>between "All" references. I can only jump from the
>>reference I have highlighted and the definition and
>back.
>>It doesn't find any other references. I tested with
things
>I
>>know have multiple references and header entries.
>>
>>Did I fail to correctly create the tags file? Is the help
>>simply wrong (or I have misinterpreted it)? Or is efte
(at
>>least the pm version) broken? I tried all the menu
>choices
>>Did I miss something? Thanks
>
>I re-read that section and perhaps it could be rewritten
>more clearly after we're done discussing this.
>
>IIRC you should be able to find all occurrences of any
>single tag, I just checked the latest eFTEPM build and
it
>seems to work, but I don't have a lot of stuff for
>checking right now.

I worked with this some more. It is probably working as
designed. It finds all the definitions of a function but
doesn't find all the places it is called from. You can start
from a place where the function is called and it will find
every definition (C++ same function in different classes).
I can return to the original caller but it won't take me to
any other place it is called from.

>
>>{0}[u:\efte_netlabs\trunk\src]
>>V:\Download\ctags-5.8_os2(1)\ctags-5.8_os2\ctags.e
xe
>*
>>SYS1002: -U is an incorrect parameter for the
>command.
>>V:\Download\ctags-5.8_os2(1)\ctags-5.8_os2\ctags.e
xe
>:
>>cannot sort tag file : No such file or directory
>>Note running it from the source directory gave the
same
>>error. Tried both 4os2 and cmd.
>
>I am not sure what these errors mean, I think ctags
tries
>to invoke some 'sort' utility when it's done and fails to
>find it, but in my experience these can be ignored most
>of the time.
>
>However, you need to check the generated "tags" file
to
>make sure this may work -- a mere stub (~338 bytes)
>may be generated and of course you won't find a thing
>using that, because it doesn't contain references.
>
>To make sure a useful tags file can be generated, all
>files ctags targets when run must be of 'known' types
>(f.e. "ctags *.cpp"), or have some support for them
>added in the config file ".ctags". In the manual I added
>support for the FTE config "language" so you can run
>"ctags *.fte" and use tags while editing the config.
>
>To properly test the feature, generate a tags file, and
>open it to see for yourself what references it includes,
>then try and move through stuff that you know is
>actually in the tags.

The tags file looks fine and it works as described above.

>
>I'm out of town until Jan 4, so I may be less responsive
>than usual depending on being able to find a good spot
>to place my laptop, the hotel wifi, etc.

Enjoy your trip. Don't worry about response time. Thanks

Happy New Year!

Gregg


Subscribe: Feed, Digest, Index.
Unsubscribe
Mail to ListMaster