List Arkiverade meddelande #44

Från: "Lewis" <> Meddelandehuvud
Oavkodat meddelande
Ämne: Re: [GNU Ports] Assertion error with pip building
Datum: Fri, 30 Sep 2022 23:33:16 -0400
Till: GNU Ports for eCS Mailing List <>

Good eyes, Dave... ;-)

On 09/30/22 10:45 pm, Dave Yeo wrote:
On 09/30/22 07:18 PM, Lewis G Rosenthal wrote:

For a project (Privoxy), I got involved in building Mbed TLS
( Mbed TLS seems to
require the Jinja2 Pyhthon module (

Unfortunately, pip (well, gcc, more likely) is having a hard time
building wheel, as a prereq for MarkupCode, which itself is a prereq for

I've hackishly worked around the problem by removing line 91 from

assert preserve_mode and preserve_times and not preserve_symlinks

What I'm failing to understand, however, is why the assertion fails in
the first place. It seems perfectly reasonable, unless I'm missing
something. Before I open a ticket for bww about this, I thought I might
mention it here, in case anyone has any ideas.


Here's a bit of the output (mind the wrapping):

Wonder about it not wanting to write to your $HOME directory, seems to fail with copy_tree

Interestingly enough, the pip subdirectory doesn't exist under .cache. I wonder if something went awry during the pip install. FWIW, I also tried building with --no-cache-dir, which simply quieted down that bit of noise (though the assertion still failed).

I'll try adding the pip directory, though.



Prenumerera: Sändning, Uppsamling, Index.
Stoppa prenumeration
Meddelande till ListMaster