Mailing List Archived Message #166

From: "Alfredo Fernández Díaz" <> Full Headers
Undecoded message
Subject: Re: [lswitcher-dev] Revisiting 2.92
Date: Sat, 28 Nov 2020 22:23:26 +0100
To: lSwitcher Developers Mailing List <>

On 20/11/28 20:33, Gregg Young wrote:
On Sat, 28 Nov 2020 12:29:08 +0100 Alfredo Fernández Díaz wrote:

Hello Gregg,

I am grateful for all the work you do on lSwitcher. However, further
testing v2.93 I am under the impression that the font stuff you are
doing on it, to paraphrase Doug, is breaking something, somewhere,
somehow, and this may take a long time to fix, so I decided to check
2.92 again, which looked much more solid with none of the 2.93 issues.

Unfortunately the whole point of 2.93 is to get the unicode, font and
codepage stuff working.

Of course. I was hoping that new info on 2.92 not breaking might inspire you to try something different to whatever you have been doing on 2.93 so far, and get stuff fixed in one fell swoop.

Remember how the PM popup hints didn't render properly on AOS
(which was by far the single biggest problem), and that I reported they
displayed just fine on older systems? Well, I got it to work -- it's
apparently an installer / file layout issue, or at least that is what
the hints needed to break.

Have you tried this same process with the 2.93 RCs?

Nope -- 2.92 was (or maybe 92rc15) the one that totally broke the PM popup hints, and the 93 rcs introduced other problems while trying to fix that. I wanted to tell you before doing anything else.

I will add this to my list of things to try in subsequent versions -- since this was not known, it may still be an issue with new code.

Also using warpin try  uninstalling lSwitcher make sure you delete the ini
file and anything else  that happens to still be in its directory then
reinstall it. Before you run it reboot to make sure the newly installed hook
is the one that is loaded.


I have several AOS systems now that show the same behavior
I deem of interest. On each, I have TWO standalone lSwitchers: one
installed via WarpIN (Hook +Common +TaskBar, default destinations), and
the other unpacked manually, with the same files on a single directory.

This sounds like either a hook issue related to LIBPATH or an old ini file
still in the install directory. It uses 4.System VIO for the hints. 2.92 used
6.System VIO. Is it possible that there is a problem with the font install
in Both sizes exist according to the font palette.

I don't know, we'll have to check.

It also uses 9.Warp Sans, 8.Times New Roman MT 30 and 8.Helv.

Every time I run the installed lSwitcher, the hints are unreadable, as
they were before. If I close the installed lSwitcher, however, and I
run the unpacked one instead, hints are perfectly fine and dandy. I can
close and switch back and forth between the two lSwitchers until I get
tired, with the same results every single time.

I hope this gives you some ideas, and helps you to get everything back
on track as soon as possible.

Of course, if you prefer that I stick to testing 2.93rc3, I will -- I
have a few more issues to report on that front.

Yes stick to testing 2.93 as I have no plans to go back to 2.92 and start over.

OK. Thank you,

Subscribe: Feed, Digest, Index.
Mail to ListMaster