Mailing List Archived Message #190

From: "Gregg Young" <> Full Headers
Undecoded message
Subject: Re: [lswitcher-dev] 2.92 vs 2.93 on MCP2 vs AOS (was lSwitcher-2-93-0-RC_4.wpi (was [...] RC_3))
Date: Sat, 02 Jan 2021 15:25:29 -0700 (MST)
To: "lSwitcher Developers Mailing List" <>

On Wed, 16 Dec 2020 12:27:46 +0100 Alfredo Fernández Díaz wrote:
>El 20/12/16 a las 00:32, Alfredo Fern�ndez D�az escribi�:
>>Now, I also installed a plain vanilla (no "international" fonts, no
>>fonts, no nothing installed on top) Spanish MCP2 system from 2001 for
>>testing -- lSwitcher 2.92 (which didn't do the settings font switch)
>>its Russian notebook just fine on that with the default font (System
>>Proportional IIRC). I tried all the fonts that pop up in the font
>>palette by
>>default (Tms Rmn, Courier, Helv) and the Russian notebook displays just
>>letting aside the clipping at 640�480. I am not a specialist in Czech
>>Polish, but they look readable to me as well, and certainly there are
>>squares nor "house" characters.
>>Just see the lSw292@MCP2 screenshots series.
>>>>Case in point: I have an older Spanish work system where naturally
>>>>Spanish non-ASCII characters are displayed correctly all the time. I
>>>>expect this may not be the case for the Global tab (CP1207),
>>>The only reason this wouldn't work is if the system predates the use
>>>of uconv.dll or if it doesn't have the Warp Sans and/or Helv fonts
>>>installed. None of which is likely.
>>Actually, I was right,
>Almost ;)
>>and I can show you on the test MCP2/es system again.
>>The only thing that did not render properly in 2.92 in it, was the
>>page with the multi-language drop-down: not even "Espa�ol", whereas
>>the other
>>pages do Spanish, Russian, etc. flawlessly. The good news is that page
>>already fixed in 2.93 without using the Times New Roman, either. Have a
>>at the "Unicode_" pair of screenshots.
>So, language support already worked in MCP2 without any fancy font stuff
>in v2.92, with only one yet notable exception: the Global tab (the only
>one that really needs to be multilingual, so it uses CP1207). This
>really irked me last night, but I was too tired to go on.
>To summarize:
>-In v2.92, non-ASCII chars in the Global tab don't display properly
>under MCP2, but they do under AOS.
>-In v2.93(rc4), the whole notebook displays properly even under bare
>So something in the difference between MCP2 and AOS was doing something
>for 2.92 that 2.93 was doing on its own. Sleeping over it, it hit me
>this morning: Styler has this 'dialog enhancing' setting labelled "set a
>dialog font default"...
>And that's it:
>In v2.92, all tabs use WarpSans, except Global -- this could be seen
>on my last screenshots using a boldish, system default font (System
>Proportional, probably) on MCP2 but not on AOS.
>On an MPC2, I installed Styler. Now, with Styler having set its dialog
>default font, everything in the 2.92 settings notebook displays
>properly, including the Global tab, which was rendered using WarpSans
>(Styler's own default, which happens to be a Unicode font) now. Turn
>that setting off, and the Global tab gets back to its 'bad' display --
>so it's that default font.
>On the same MCP2, v2.93 already uses WarpSans explicitly for all
>its notebook tabs, so Styler doesn't make a difference (not that it
>should even try unless you check another setting called "replace even
>explicitly set fonts" owtte).

The difference is I now explicitly set the font most every where which wasn't the case in 2.92. Thanks


Subscribe: Feed, Digest, Index.
Mail to ListMaster