Mailing List lswitcher-dev@2rosenthals.com Archived Message #20

From: "Gregg Young" <lswitcher-dev@2rosenthals.com> Full Headers
Undecoded message
Subject: Re: [lswitcher-dev] 2.90 RC was Re: [lswitcher-dev] lSwitcher documentation issues and functional clarifications
Date: Sat, 21 Oct 2017 14:18:27 -0600 (MDT)
To: "lSwitcher Developers Mailing List" <lswitcher-dev@2rosenthals.com>

On Sat, 21 Oct 2017 14:40:21 -0400 Lewis wrote:
>
>Hi, guys...
>
>On 10/21/17 01:44 pm, Doug Bissett wrote:
>>On 2017-10-21, at 10:28:34, Gregg Young wrote:
>>>Hi Doug
>>>
>>>>>I have updated the settings notebook and made
>>>>changes
>>>>>to the standalone taskbar desktop menu based on
>>>this
>>>>>thread. I have not addressed the Scroll message
>>>>divider.
>>>>>It also should fix the system specific install,
>pmprintf
>>>>>dependency and installs the help in the help path.
>>>>>
>>>>>Let me know what you think. Thanks
>
>Looks like we're not detecting ArcaOS. Help defaults to
><bootdrive>\eCS\HELP which does not exist on
ArcaOS.

This works here with 2.82p. The help install to a directory
in the HELP PATH is going away. I found away to get
the settings notebook to find the help file without it.

>I also get another copy of lswitch.hlp in the program
>directory *and* in the widget directory. :-) Now, I
>understand the reasoning behind having the second
copy
>in the widget directory, but the one in the program
>directory should not be required if we're installing to a
>directory in %HELP%.

There will only be one in the program directory and one in
the widget directory going forward.

>
>Have you committed the latest WIS, Gregg? I can take
a
>look at it, if you like (still getting the footnotes fixed in
>the help...).

They work as is. Get the version I just commit ed with
the  warnings fixed.

I haven't committed the latest wis. Let me remove the
help package and add a "DOS" package. Then I will
commit it.

>
>>>>I tried lswitcher-2-82p.wpi (which was attached). It
>still
>>>>requires
>>>>PMPRINTF.
>>>Off now.
>>Promise?  :-)
>
>:-)
>
>>>>I tried the widget version. A quick test seems to be
>>>good.
>>>>Help shows
>>>>up when requested (I didn't read much of it).
>>>The help has just been updated by Lewis anyway.
>
>Getting there.
>
>FWIW, I moved the changes back to the History text
file,
>and just inserted a one-liner in its place directing the
>user to History located in the lSwitcher installation
>directory.

You could put it an external link and use e.exe to open
the history.

>
>I also linked in the text of the GPL v2 as License, and
>changed License to Copyright, trimming the redundant
>disclaimer of warranty from that section.
>

All fine with me.

>I still need to review the context sensitivity to make
sure
>I haven;t broken anything and to see what's up with the
>"nervous" behavior when opening a page from the
>Properties notebook.

In a quick test it all appeared to work right.

>
>>>>I tried the stand alone version, and put the bar to
the
>>>top
>>>>of the
>>>>screen. Overall, it looks okay. Again, I didn't read
>every
>>>>word in the
>>>>help.
>>>>
>>>>One thing, that I am seeing, is that the bar flashes
>>>>white, every once
>>>>in a while, for no apparent reason (standalone
>version).
>>>I think what you are seeing is the focus changes.
The
>>>window with focus is highlighted and the highlighting
>>>changes as you change the window with focus,
>>I don't think so. I see the flash when nothing is
>happening. Changing
>>the focus doesn't seem to do it.
>
>Interesting.
>
>>>You probably have the widget set to 3D look where
>the
>>>highlighting is more subtle. Maybe I should make the
>3D
>>>look the default.
>>3D was on, so I turned it off. I still see the flash.
Then,
>I tried the
>>rest of the settings. The only things that stop it, are
>Enable, and
>>Auto hide. Both sort of defeat the purpose of having
>the bar.
>>
>>There is no pattern to it. Sometimes it goes about 5
>minutes without
>>doing it, and other times, it will do it 6 times in a
minute,
>even when
>>I don't touch anything. I would think that it is doing
>some sort of
>>display refresh, but I don't know why it would be doing
>that, nothing
>>changes.
>
>I always use:
>
>Enabled
>Auto hide
>Flat buttons
>3D look
>Icons only
>
>Bottom of screen
>
>Perhaps I'm not seeing it because I auto-hide it. I'm
>doing another test install and will keep it visible.
>

I see it here. It seems to happen by moving the mouse
pointer from one window to another but it isn't
consistent.


>[time]
>
>On the test box I *can* confirm this flashing behavior.
>For me, once I turned off Reduce Desktop workarea
>(which, BTW, is specifically mentioned in the known
>issues to *possibly* conflict with XCenter's option of
the
>same name - or anything else reducing the Desktop
>workarea), the flickering stopped. Please confirm that
>this is not the case for you, Doug.

It happens both ways here.

>>>I
>>>>don't see
>>>>that with the widget. Some people could have
>serious
>>>>problems with
>>>>that.
>>>>
>
>Indeed, on the test system (one of the boot volumes
on
>the T520), I've been using the widget, and have not
>seen this (Panorama).
>
It doesn't happen with the widget. Of course that
actually improves my chances of finding what is doing it.

I have an addition issue I have removed the Scroll
message divider. It now looks up the the lines per scroll
for AMouse in OS2.INI and uses that value. Does
SMouse have a similar setting?  

Now the problem. With AMouse scroll wheel, Alt+scroll
wheel and Ctrl+scroll wheel are all set separately. The
result is if I use Alt+Tab I have to have Alt+scroll wheel
set to scroll messages same pattern for Ctrl. However,
with the sticky window it uses just scroll wheel.

I don't see a way to change this in lSwitcher. Additionally
the lines per scroll can be set differently for each one
(most people probably wouldn't do that). Right now the
Alt/Ctrl+scroll wheel default to no function. While I could
change that in os2.ini its probably not a good idea. I am
guessing we should document this mess or I could just
remove the mouse wheel related code.

Thanks

Gregg


Subscribe: Feed, Digest, Index.
Unsubscribe
Mail to ListMaster