Mailing List Archived Message #212

From: "Alfredo Fernández Díaz" <> Full Headers
Undecoded message
Subject: Re: [lswitcher-dev] lSwitcher-2-93-0-RC_6.wpi
Date: Mon, 16 Aug 2021 11:38:26 +0100
To: lSwitcher Developers Mailing List <>


I haven't got my previous message back from the list (Lewis? 'cos of the REXX attachment?), so here's an update for you all (minus my REXX script),

On 2021/08/15 21:52, Gregg Young wrote:
Hi Lewis

This is a warpin bug. REQUIRES="Ulrich Möller\XWorkplace\Kernel\1\0\1" isn't meant
to be user  readable it is an internal check.

It turns out the main problem is not a WarpIN bug but a packaging goof.

Whoever created the Russian XWP package specified CODEPAGE="866" in the WIS. This may seem reasonable because there's quite some Russian text in there besides the *** English GPL. Unfortunately, that overlooks the fact that the o-umlaut in Ulrich's surname can't exist in a CP866-encoded file, as Gregg noted.

Going back a bit, right after ArcaOS installs:

English and Spanish system WarpIN databases contained "55 6C 72 69 63 68 20 4D C3 B6 6C 6C 65 72" which is valid UTF-8 for "Ulrich Möller", which means all code worked correctly to build it.

On my Russian WOS system, the database contains "55 6C 72 69 63 68 20 4D D0 A4 6C 6C 65 72", which is not valid UTF-8 whatsoever. (D0A4 seems to be a Hangul character in UTF8, BTW.)

Which of course is totally unrelated to lSwitcher or its WIS.

After ruminating over this for a bit, the key question was, why in the world would WarpIN translate the same input string (Ulrich Moeller) into the same encoding (UTF8) differently on a Russian system? The first logical step was to stop assuming the input was indeed the same, and check it - and bingo!, see above.

I removed the o-umlaut from the Russian XWP WIS, converted it to UTF8, and added the o-umlaut back in place. I then removed the original XWP installation from the Russian system and installed mine. Besides text display being mangled during installation (which IS a WarpIN bug), everything worked fine, and the lSwitcher WIS no longer gives a warning, because XWP is properly detected.

So... nothing else to be done about this regarding lSwitcher packaging, etc. :)

OK some questions about this. What version of iconv are you using I have found several?
What are the exact steps to build the wis? I assume you need to reconvert any time you edit the file unless
you use a UTF-8 enabled editor (are there any).

IIRC iconv has always had problems. I have put together a little REXX script to use Alex Taylor's ULS to convert text files between codepages, find it attached to my previous message. Alex also has an UTF8 capable, QT-based editor somewhere, but I can't recall the name right now. And then there's File Commander/2's internal editor.

Thank you,

Subscribe: Feed, Digest, Index.
Mail to ListMaster