Mailing List Archived Message #41

From: Lewis G Rosenthal <> Full Headers
Undecoded message
Sender: os2-netware_users-owner <>
Subject: [OS2NetWare] Anyone tried SAMBA to access NetWare CIFS?
Date: Sun, 07 Nov 2004 21:21:03 -0500

Some good news:

I needed to build a workstation for a client this week, and while I haven't yet deployed it, I wanted to do a quick eCS 1.2 test install on it (with a different drive; this client is getting that other...ahem..."lesser" known operating system produced in Redmond, WA). (You'll see where this is going with regard oto the subject momentarily.) The hardware in the box is:

AOpen S651M SiS-based system board with onboard audio/video/LAN/USB
Celeron D 2.4GHz (these are the latest generation of Celerons, which are supposed to be equivalent to last year's P4's)
512MB DDR/333 RAM
1.44 FDD


eCS 1.2 installed without a hitch, using the UNIAUD driver for the onboard Realtek audio. I had to use the GenMAC driver for the onboard NIC, however, as the 2002 SiS 900 driver didn't want to work (I saw this the last time I did a similar machine, even though the chip is indeed an SiS 900). USB works fine, and video, of course, using SNAP is great.

I only installed TCP/IP, NetBIOS, and TCPBEUI. Next I did some playing against my W2K Advanced Server (which runs Citrix over here), and Peer Services worked fine (both directions). No surprise there. It was no surprise, either, when I couldn't see the CIFS exports on the NetWare 6 box. However, here's the fun part...

I went to Blueprint Software and grabbed the version of NetDrive for the SAMBA plugin which does not timeout (i.e., it's free, not a time-bombed eval), and then went over to NetLabs to grab the SAMBA plugin. I installed NetDrive first, created a shadow of the SAMBA daemon in the Startup folder, rebooted, and installed the SAMBA plugin dll. After one more reboot, I set up NetDrive to mount the SYS volume on the server as drive F:, and lo and behold, it worked. The speed wasn't too bad, either. Pure IP, gang; no IPX on the wire at this point. Pretty cool.

Now the odd stuff: When browsing directories from the WPS object for the NetDrive-attached drive, WPS had a tendency to hang. I can't tell whether this was the SAMBA plugin, WPS, or ND. WPS wouldn't restart, either, forcing a reboot. Also, as I suspected, SAMBA doesn't support EAs. Unlike NFS, however, it doesn't warn that the EAs will be discarded, they just are. So, while there's promise, there's still limited use.

Anyway, that's my report!

On 09/23/2004 10:16 pm, Lewis G Rosenthal thus wrote :

Theoretically, it should be possible to access NetWare volumes published for Windows native file access (CIFS). Has anyone tried this? I don't use any of the peer networking components in OS/2, but I'm wondering whether Peer services might be able to browse Netware drives published as CIFS.

Nothing important...just a few wandering (and wondering) thoughts...

Happy Fall.

Lewis G Rosenthal, CNA Rosenthal & Rosenthal Accountants / Network Consultants  New York / Northern Virginia 
Team OS/2  / NetWare Users International
------------------------------------------------------------ =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

To unsubscribe from this list, send a message to with the command
"unsubscribe os2-netware_users" in the body
(omit the quotes).

For help with other commands, send a message
to with the command
"help" in the body (omit the quotes).

This list is hosted by Rosenthal & Rosenthal
P.O. Box 281, Deer Park, NY 11729-0281. Non-
electronic communications related to content
contained in these messages should be directed
to the above address. (CAN-SPAM Act of 2003)


Subscribe: Feed, Digest, Index.
Mail to ListMaster