Poštni seznam arhiviranih sporo?il

Od: "Rick R." <os2-wireless_users@2rosenthals.com> Glava
Izvorno E-sporo?ilo
Zadeva: Re: [OS2Wireless]Changed -> SOCKET.SYS crash - I give up
Datum: Sun, 13 Aug 2006 17:16:19 -0700 (PDT)
Za: OS/2 Wireless Users Mailing List <os2-wireless_users@2rosenthals.com>

This one is going to be LOOON as well, sorry.
Lewis, when people tell me that its in essence "my fault", even so those SOCKET.SYS crashes are both unacceptable SW flaws and should not be happening any more AS I PATCHED EACH AND EVERY DRIVER that the official IBM bug report claims needs patching, then I recon I got the right to respond picky after I just lived through 48 hours of CONSTANT CRASHES!
That everyone else got to read that, too, I'm sorry for, but that's the nature of this mailing list - if I could have addressed my reply to just one person then I would have.
Neil's reply was both utterly unhelpful as insulting by itself.
To tell someone whose driver's won't work: "go to eBay and buy a Thinkpad", is about as helpful as telling a guy whose car won't start on his way to work: "go to eBay and buy a new car" - Heellooo, help me get my car running please or just keep smiling.
But don't give me advise that is more like advice.
That I already have a Thinkpad and have been using TPs for the last 5 years is just an added "bonus" here.
In any case, there are no "skeletons" in my closet.
I had those SOCKET.SYS crashes for years and I applied all the patches I could find on the Internet to get rid of them.
I patched single files, I patched the entire package, I checked time stamps by hand.
Sometimes it seemed to work, only to then start crashing again (sometimes 2-3 weeks later).
So I accepted having to live with just the occosanial crash every now and then.
But now I installed VPN tunnel and other SW that keeps my Internet connection bz all the time.
I have to down- & upload gigabytes of files and the result is CRASHES, CRASHES, CRASHES.
Those XPIs only increased NW traffic, but that should not cause the stack to blow.
So when people just blamed it on the XPIs, as "a quick way out", I thought that was less than helpful.
I don't need a flawless box, but how can I dare to use my system for work if it crashes all the time? I'm a computer consultant and that just makes me look foolish.
And no, there are no RAM or "hairline crack" isues here.
Both my Windoze a my TCP/IP stackless OS/2 maintenance partition work completely w/o crashes after using them for hours or even days at a time.
And migrating from an A30 to a T42p is really quite simple under OS/2.
I just de-installed all HW specific drivers (LAN, WiFi, sound & USB), reset video to VGA and then did a partition copy with DFS.
Afterwards I installed those drivers again, changed some settings in config.sys and I was in business.
And no, no one ever told me I could just "migrate my system to eCS".
Instead they told me that I'd loose most of my current configurarion as the eCS install is an INSTALL, not a migration tool.
My setup is very complex, both on WPS, as on config.sys and CMD level.
I use 4OS2 heavily, together with a complex TVFS tree and online encryption.
I have over a dozen different file systems emulated on my box, I use Win32 and Unix tools seamless on it as well.
I use XFree86/2 together with HobLink's X11 and 4 different Java implementations.
I have Oracle, Sybase, DB/2 and MySQL running on my system, together with gcc, VisualC++, Pascal, Forth, Fortran, COBOL and SlickEdit.
I use OpenOffice, Lotus SmartSuite and Lotus Net, together with Maul, Papyrus and then some. And and and.
When I asked if I could keep my current configuration or would risk loosing it, I was told I'd likely end up with a new install for most of those.
I don't think so. But I did purchase both an eCS1.2 and 2.x license and I applied all the patches from Serenity's website for years now (the TCP/IP patches as well!).
So I really wonder what eCS 1.2 has that my current OS/2 box doesn't?
Maybe you can educate me about any specific functionallity I'm missing here and I haven't seen any production release of 2.0 yet.
Woaah and now back to regular programming...

Lewis G Rosenthal <os2-wireless_users@2rosenthals.com> wrote:
My apologies to everyone for the length of this post. Rick, my reply
appears below your text.

On 08/13/06 02:04 pm, Rick R. thus wrote :
> The extensions work just fine under FireFox/2. Indeed almost all of
> them do (including some fancy weather radar stuff).
> Its just the added network traffic that causes the SOCKET.SYS error to
> appear that more often.
> Yet I had the same appear already during FTP sessions or heafty
> browser window swapping.
> None of those "official" patches worked!
> But I won't simply try to avoid using the Internet at all cost, just
> to compensate for a brain damaged TCP/IP stack!
> Whoever wrote those dumb ass drivers anyway?
> Not even under Windoze did I ever encounter such a basically flawed
> driver stack!
> If the price for using OS/2 is to lack behind all others, then its a
> price to high to be paid!

Rick, let me just make a couple points and hopefully get you moving in
the right direction:

1. This is an all-volunteer, user-to-user mailing list which is
focused on wireless connectivity under OS/2 and eCS. It is *not* a
"bash IBM," "bash OS/2," "bash eComStation," or "lash out at
anyone and everyone for Heisenbugs
(http://en.wikipedia.org/wiki/Heisenbug) or perceived networking
inadequacies in any operating system or other software, which may
or may not appear in a given OS/2 setup.
2. As others on this list use the same build of OS/2, GenMAC, TCP/IP,
and Firefox as you are using, and as those same people are not
experiencing the same issue(s) you seem to be having, blaming your
problems on a "basically flawed driver stack" is a bit off-base.
Evidently, either there is something odd about your hardware or
software which is causing these issues or your configuration is a
bit mucked up; the later build of GenMAC seems to have better
exposed the problem(s), that's all.
3. You are free to stop using OS/2 anytime you wish. None of us here
has a financial stake in your decision. We are willing to help
track down the problem, but we are not here to listen to you vent
uncontrollably. We have all been frustrated by elusive issues at
one time or another; we just tend to band together to do what we
can to help each other out. What holds us together is a mutual
respect and admiration (some for their knowledge and willingness
to assist and share; others for their perseverance and willingness
to test new things and ideas to try to track down the problem).

This is an unmoderated list. In general, I don't like to get involved in
commenting on the rhetoric it sometimes conveys. However, that being
said, there are times when I feel it may be necessary to remind people
of why this list exists and the lack of monetary reward for anything it
provides (essentially, you get what you pay for; the advice is free, so
take it or leave it, but don't complain about it).

I told you that I would pursue the mater on your behalf with Serenity
Systems as a registered consultant and reseller, and I shall. I do
apologize for unrealistically claiming that I would do it the other
afternoon, when I was so entrenched in the business of the day. I will
pick up on it tomorrow, and keep you posted. I seem to have missed your
post of August 9, wherein you mentioned that you were not running eCS,
but rather WSeB, due to the lack of an upgrade path to eCS (which is not
entirely true; there is a migration facility included with eCS to ease
the transition of your desktop and applications). Frankly, unless you
can reproduce the issue under eCS, it's going to be difficult to get
Serenity to address it. It is hard to believe, considering the age of
WSeB, that this issue just now cropped up and yet is supposed to be
related to a broken TCP/IP stack.

I have provided a couple suggestions for you without specifics on your
system. Others have offered their suggestions, as well.

To Neil Waldhauer, who suggested that you locate an(other) IBM ThinkPad
from eBay, along with a supported Wi-Fi card, you responded:

Don't be so presumptious.
And there are no native WiFi drivers for the T42p.
So I got to use GenMAC.

Your second line is both insulting and completely out of line; this was
uncalled for. Neil explained that he has several systems - supposedly
using the same TCP/IP stack as yours - which are working well, without
the issue you describe (and frankly, bad RAM could be the root of your
trouble, as well as a hairline crack in either the system board or the
Wi-Fi card itself, notwithstanding your point about seeing a similar
problem - though less often - on your T30).

Have you tried swapping the RAM (or alternately removing one memory
module and then the other) on the systemboard?

Roderick Klein's comment about the OS/2 stack being "not that bad" is
well taken; OS/2 inherited much of the stack from AIX, and while it is
now somewhat dated in its feature set (only a single DHCP interface and
so forth), it is in general quite stable.

In fact, in all of this, you have never - AFAICT - listed the *exact*
error, crash, or trap you get in SOCKETS.SYS, which would be a big help
in troubleshooting the underlying problem (and no, I don't believe that
Firefox or any particular extension is at fault). A TRAP003, TRAP00D ,
and TRAP008 are completely different things, and while classifying them
all as "crashes," each may point in a completely different direction.

On August 9, you mentioned that you saw this problem before (though
admittedly less often) on your T30 without using GenMAC. As you did not
migrate your system to eCS, I'm curious as to how you made the
transition from the T30 to the T42 without a clean install. If hardware
isn't the issue, then we need to determine what skeletons were in the
closet before you made the hardware move (my T30 was quite stable, and
did not suffer problems with SOCKETS.SYS AFAICR).

From your post of August 10:
> I am using the E1000 driver on my T420.
> PCI scan:
> Vendor 8086h Intel Corporation
> Device 101Eh 82540EP Gigabit Ethernet Controller
> (Mobile)
I didn't see which version of the E1000 driver you are currently using,
or whether you have tried moving back (or forward) a revision to test.
> Vendor 168Ch Atheros Communications Inc
> Device 1014h 11a/b/g Wireless LAN Mini PCI Adapter
> And I'm only using the WiFi connection now.
> But the same did happen when I used the wired
> connection.
Does "currently using" mean that you simply don't have a cable
connected, or that you do not have the driver loaded in CONFIG.SYS and
not present in PROTOCOL.INI? Also, for GenMAC, try the following in
PROTOCOL.INI: in the section for your Wi-Fi driver, try the following


(Dave, don't ask me what this does, as I'm still not clear. However,
there was a posting about it on the GenMAC user list some time ago,
which seemed to cure some stability issues for some of us, so I adopted
it early on while getting my Intel 2915 working.)

However, the above might only address GenMAC's exposure of the
underlying problem and not the issue itself (you mention that the
problem appears more frequently with GenMAC 1.7).
> Fact is, I am not able to use WiFi and Wired at the
> same time if they are both on the same network.
> The first one to be activated seems to cancel the
> other out.
That is correct behavior, and unless you use a teaming NIC driver (such
as those provided for certain server configurations), where the two
drivers are actually "bonded" together to form a single logical NIC, you
do not want both NICs connected to the same network. Scan through the
archives of this list, to read Christian Langanke's comments - and the
ensuing discussion - concerning this type of arrangement. (And please,
everyone, let's not get farther OT in this thread by arguing the point;
for now let's accept that this is where we are, and focus this thread on
Rick's problem.)
> I can only use both if they are on different networks.
Correct, per above.
> Finally, how can I stop "wlanstat.exe" from displaying
> the splash screen and blinking all the time?
I have no idea; sorry. Perhaps this is a symptom of the problem you are
experiencing? A resource conflict somewhere?

Do you have a spare drive on which you might try a clean install of eCS?
This might also help eliminate the hardware as a point of failure.

This post has taken me well over an hour to prepare. My wife is now
looking at me cross-eyed, as I have been holding up dinner, and my kids
are famished. My point is not that I'm hungry and have an angry spouse
and rapidly thinning children, but that I'm happy to take the time to
help and offer what I think may be substantive commentary; all I ask is
the same cordiality in return, and not the impatience I've seen of late.

Lewis G Rosenthal, CNA, CLP, CLE
Rosenthal & Rosenthal, LLC
Accountants / Network Consultants
New York / Northern Virginia www.2rosenthals.com
eComStation Consultants www.ecomstation.com
Novell Users Int'l www.novell.com/openenterpriseserver
Need a managed Wi-Fi hotspot? www.hautspot.com

This message is sent to you because you are subscribed to
the mailing list .
To unsubscribe, E-mail to:
To switch to the DIGEST mode, E-mail to
To switch to the INDEX mode, E-mail to
Send administrative queries to
To subscribe (new addresses), E-mail to: and reply to the confirmation email.

This list is hosted by Rosenthal & Rosenthal
P.O. Box 281, Deer Park, NY 11729-0281. Non-
electronic communications related to content
contained in these messages should be directed
to the above address. (CAN-SPAM Act of 2003)


Do you Yahoo!?
Everyone is raving about the all-new Yahoo! Mail Beta.
Naro?iti: Poro?ilo (Feed), Izvle?ek (Digest), Indeks.
E-pošta za mojstra za sezname