Mailing List Archived Message #126

From: "Doug Bissett" <> Full Headers
Undecoded message
Subject: Re: [Virtualized eCS] Virtual box 6.0.14 r 133895, acpi shutdown with AOS 5.0.3 and virtual cpu - 2 cpu success
Date: Tue, 14 Jan 2020 22:33:18 -0700 (MST)
To: "Virtualized eCS Users Mailing List" <>

On 2020-01-14, at 17:32:52, Massimo S. wrote:

>>>i reinstalled the guest VM AOS 5.0.3 with ACPI modern
>>>and now it see 2 virtual CPUs
>>I will be surprised, if that doesn't cause hangs.
>it seems rock solid stable

I tried a new install of ArcaOS 5.0.4 (I have 5.0.3, but it isn't
handy). I can't even get it to boot if I enable a second processor. It
either hangs, can't find a file, or I get a kernel trap. One processor
works properly. This is the same things that I see, if I enable
HYPERTHREADING in a real machine.

>>>shutdown ACPI function still don't work
>>How, exactly, are you doing the shutdown? I always use RMB
>>select shutdown. From there, you have options.
>the button on the application bar at the bottom of the screen
>the VM repains open, even if the guest OS has shutdown

I am still not clear what is happening. I did a new install, because I
always remove the XCenter shut down button (I have better things
to put in XCenter, and there is limited room in the bar). The
XCenter shutdown button takes me to the same place that RMB->
Shut down takes me. It turns off, with no problem. The VirtualBox
Manager window is still open (just close it), but the VM is shut

>>>i've also a small issue
>>>i must install boot manager to make the guest OS in the VM to
>>>even if i have the primary partition (about 4GB JFS) startable
>>>the VM don't boot without boot manager
>>If you have only ONE boot volume, and it is drive C:, and it is a
>>primary partition, you don't need Boot Manager (and, I hope you
>>mean Air Boot, not the ancient Boot Manager, which can have
>>problems with ACPI).
>my C: is JFS primary startable 3999 MegaBytes
>the VM don't boot from disk
>i'm forced to install Airboot (the one that install automatically
>i'd like that AOS could boot directly :(

I can't even imagine what is causing that. I have never had that
problem, and I have installed ArcaOS (various versions), many
times. If I use a boot drive letter other than C:, or if I make it an
extended partition, or if I make more than one boot partition, I do
need Air Boot (or Boot Manager), as expected (same as on a real

It appears that you are doing something wrong, but I don't know
what it might be.


From Doug Bissett's ArcaOS system
dougb007 at
... I miss the days when everything worked with just an "ON" and "OFF" switch.

Subscribe: Feed, Digest, Index.
Mail to ListMaster