Mailing List Archived Message #142

From: "Massimo S." <> Full Headers
Undecoded message
Subject: Re: [Virtualized eCS] Virtual box 6.0.14 r 133895, acpi shutdown with AOS 5.0.3 and virtual cpu - 2 cpu success
Date: Fri, 17 Jan 2020 20:08:04 +0100
To: Virtualized eCS Users Mailing List <>

Il 17/01/2020 19:33, Doug Bissett ha scritto:
On 2020-01-17, at 15:38:29, Massimo S. wrote:

Il 17/01/2020 14:27, Massimo S. ha scritto:
Il 17/01/2020 13:13, Massimo S. ha scritto:

Il 17/01/2020 11:27, Massimo S. ha scritto:

Il 17/01/2020 03:49, Doug Bissett ha scritto:
On 2020-01-16, at 21:54:31, Massimo S. wrote:

...snip the CONFIG.SYS details...

It appears that you have defined two NICs. The ancient
PCNTND.OS2 driver is for an old 100 Mbs NIC. I suggest
using the
network driver for the Intel 1000 Mbs NIC (the first one in the
works well). BigIcons are also not necessary. If you don't
those things, deselect them in the installer. Randomly
REMing lines
in CONFIG.SYS is not the best approach.
Doug, i'm in "trouble" :)

i've put Intel pro 1000 but i'm not finding a single driver that
works with
this configuration

altready tried, but they don't work

e1000.os2, ibmgc.os2, ibmge.os2, mmigb.os2....  :(

after some while eith the classic intel driver E1000B.OS2 it
seems to

but datarates are poor, just like with AMD PC net III 100Mbit

max. download datarate VM -> laptop via ftp 5-6
more than a local machine it seems a remote server connected
via a 100Megabit FTTC  :(

any help?

i've now moved the VM on a SATA3 SSD
but the ftp datarates are the same than when it was on an old
7200 RPM
HDD :(

explained the mistery!

i've seen that also copying a file from a partition to another in the
guest VM had the same datarate.... :(

so i realized that it was DANIS

now i've put only /!BIOS option into danis driver in config.sys
and i get 18,7MegaBytes/sec datarates that's not so good
but surely better

any hint to speed up it?



Well, first, don't use IDE disk attachments (and /!BIOS is the default
install option, for a reason). Change that to SATA (AHCI), and use
"/f /n" on the OS2AHCI.ADD line, in CONFIG.SYS. Also, define the
disk drive as being a SSD, or VBox will insert seek delays (it
doesn't matter what the real disk is). Don't try to change it without
first preparing the guest with the proper drivers.

thanks for the hints i tried, but..

i went back on IDE storage

IDE+SSD (danis): 121-135MegaBytes/sec
SATA+SSD (os2achi): 55-71MegaBytes/sec

copy a 5GB files on the same JFS partition


Whether that will speed up FTP, or not, I don't know. FTP is not
governed by disk speed, it is governed by the slowest link in the
whole chain, and that is usually something in the network. 18 MBs
is not that bad. Also, be aware, that windows changed their method
of calculating network transfer speed, about a year ago. I used to
see 20 MBs in windows, and about 16 MBs in OS/2. Now, I see
about 16 MBs in both. I have no idea what is slowing the transfer
(windows obviously got caught cheating on their performance
numbers). I can start a second transfer (from a windows machine),
using a second computer, and the same server (the old P4), and it
shows 30 MBs. Starting a third system, it will hover around 40 MBs
on the old P4, so it isn't the slower computer, it isn't the network,
and it isn't IDE, that is slowing it (the P4 doesn't support AHCI).
OS/2 to OS/2 does the same thing.

Subscribe: Feed, Digest, Index.
Mail to ListMaster