Mailing List Archived Message #152

From: "Massimo S." <> Full Headers
Undecoded message
Subject: Re: [Virtualized eCS] Virtual box 6.0.14 r 133895, acpi shutdown with AOS 5.0.3 and virtual cpu - 2 cpu success
Date: Mon, 27 Jan 2020 13:31:51 +0100
To: Virtualized eCS Users Mailing List <>

Il 27/01/2020 12:35, Massimo S. ha scritto:

Il 18/01/2020 17:29, Doug Bissett ha scritto:
On 2020-01-18, at 10:59:28, Massimo S. wrote:

Il 17/01/2020 18:41, Doug Bissett ha scritto:
On 2020-01-17, at 11:27:51, Massimo S. wrote:

Il 17/01/2020 03:49, Doug Bissett ha scritto:
On 2020-01-16, at 21:54:31, Massimo S. wrote:
...snip the CONFIG.SYS details...
It appears that you have defined two NICs. The ancient
PCNTND.OS2 driver is for an old 100 Mbs NIC. I suggest
network driver for the Intel 1000 Mbs NIC (the first one in the
works well). BigIcons are also not necessary. If you don't want
those things, deselect them in the installer. Randomly REMing
in CONFIG.SYS is not the best approach.
Doug, i'm in "trouble":)

i've put Intel pro 1000 but i'm not finding a single driver that
this configuration

altready tried, but they don't work

e1000.os2, ibmgc.os2, ibmge.os2, mmigb.os2....:(

In the VBox Network setup, select "Intel Pro/1000 MT Desktop
(8254OEM)". When you install ArcaOS, it will automatically
the Multimac MMLEM driver. That has always worked, for me. If
really do need a second NIC, select the same for Adapter 2.

i don't tried MMLEM since i heard somewhere that's not anymore
supported, am i right?

No. The ancient IBM drivers, and the early Multimac drivers
(E1000B, etc.) are no longer supported (they may still work,
depending on the hardware, but they have been replaced for a
reason). They were replaced by the later Multimac drivers
(MMLEM, etc. based on BSD drivers). Only the later Multimac
drivers (BSD) are supported (if you have a valid Arca Noae
software subscription). There are a few other differences.
Depending on the system capabilities, they*may*  use the MSI
interrupt method (requires a recent version of ACPI), which takes
some of the load off of the interrupt hardware (which is already
being done by software, in a VM). A few other device drivers*may* use the MSI interrupt method too.

It all fits together, and trying to eliminate parts of it can cause
unexpected problems. I suggest putting it together as the Arca
Noae installer builds it, and don't change that, unless you are very
familiar with the internal operation of modern OS/2.

Hi Doug,

i've moved to MMLEM.OS2 AN driver (1.1.3), but i'm still seeing poor datarates 4,7-6MegaBytes/sec  laptop -> AOS 503 VM
(the VM is hosted on a intel xeon 8 cores supermicro server)


more tests:

virtual-nic: AMD 1core 2,5MB/sec
virtual-nic: AMD 2core 3,5MB/sec
virtual-nic: MML 2core 4,5MB/sec

with MMLEM is syrely better
but very far for a VM that has his storage on SSD
and connected with Intel Gigabit NICs

any help?


Subscribe: Feed, Digest, Index.
Mail to ListMaster